Horn signal and speedo (tacho) kaputt

Die Mutter dieses Forums.
XF-Schwede
schaut sich noch um
schaut sich noch um
Beiträge: 19
Registriert: 24. Mai 2011, 21:36

Horn signal and speedo (tacho) kaputt

Beitragvon XF-Schwede » 12. Apr 2018, 21:49

Hello,

Again, apologies for writing in English. Mein Deutsch ist ja zu schlecht...

Have someone experienced these problems? Is there any correlation with them?

After winter sleep in non-heated garage and a unusually cold and long winter, spring wakeup for the bike meant three errors.
- Speedo (tacho) stopped working during the ride (worked for maybe 300 meters then just showed 0)
- Horn signal dead
- Side stand killer not working.

During the ride it was + 3 degrees C (37 F).

Today temp soared to an amazing 10-12 degrees C, bike enjoyed additional boost from electric heater in the garage. This resulted in side stand killer working, but horn and speedo is still kaputt.

Any advice on how to troubleshoot this problem in a simple way?

Benutzeravatar
takoda
Spezialist
Spezialist
Beiträge: 331
Registriert: 19. Mai 2016, 18:33
Wohnort: Wuppertal

Re: Horn signal and speedo (tacho) kaputt

Beitragvon takoda » 12. Apr 2018, 22:05

I've had that speedo problem a few times so far, it was always due to the plug on the back of the speedometer unit being slightly loose. Pressing it back into place solved the problem for me. Did you check the plug and socket?

As for the side stand killer, sounds like it might've just been frozen... and corrosion probably killed your horn. Did you check the contacts on both the horn itself and inside the switch?
...still out here in the wind and rain ~ I look a little older but I feel no pain...

XF-Schwede
schaut sich noch um
schaut sich noch um
Beiträge: 19
Registriert: 24. Mai 2011, 21:36

Re: Horn signal and speedo (tacho) kaputt

Beitragvon XF-Schwede » 15. Apr 2018, 21:39

Danke für die Antwort :-)

The contact on the speedo, is that on the back of the display? Meaning, you have to take the screen of to be able to reach it? I haven´t done that yet.

The plug to the horn: are you meaning the relay under the seat (according to the manual)?

Haven´t had a chance to work more with the bike yet. Hoping to get a chance tomorrow, to look at the places you suggested armed with contact spray...

Best regards,

David

Benutzeravatar
Maad
Site Admin
Site Admin
Beiträge: 1140
Registriert: 19. Nov 2003, 21:06
Wohnort: Oberhausen

Re: Horn signal and speedo (tacho) kaputt

Beitragvon Maad » 16. Apr 2018, 08:42

Hi,

:welcome:
When you can't solve the problem with contact spray, take a, look at a part named “Tachorotor“.
It is on the left side of the frontwheel hub behind the black cap. Old lubrication grease can get solid and cause broken wings on the Tachorotor.

Regards
Marek

Benutzeravatar
takoda
Spezialist
Spezialist
Beiträge: 331
Registriert: 19. Mai 2016, 18:33
Wohnort: Wuppertal

Re: Horn signal and speedo (tacho) kaputt

Beitragvon takoda » 16. Apr 2018, 10:51

XF-Schwede hat geschrieben:The contact on the speedo, is that on the back of the display? Meaning, you have to take the screen of to be able to reach it? I haven´t done that yet.

Yep, that plug is on the back of the display. I haven't taken the screen off yet, either, so far I always managed to refit it "from above", lucky me I've got fairly slender fingers *lol* Then again that might be why it's a recurring "problem" for me, so yeah, removing the screen is probably the best way to go.

XF-Schwede hat geschrieben:The plug to the horn: are you meaning the relay under the seat (according to the manual)?

No, I wasn't talking about the relay, I meant the cables that lead directly to the horn assy on the front fork. Maybe a cable is loose or the contacts are corroded. If that's not the problem, you could try opening the switch assy on your handlebar... I've heard stories about spiders moving in there during the winter and their webs putting switches out of order... tiny reason, big problem, but at least easily solved. And if there is no spider, some contact spray might still work miracles! ;)
...still out here in the wind and rain ~ I look a little older but I feel no pain...

XF-Schwede
schaut sich noch um
schaut sich noch um
Beiträge: 19
Registriert: 24. Mai 2011, 21:36

Re: Horn signal and speedo (tacho) kaputt

Beitragvon XF-Schwede » 19. Apr 2018, 20:14

The horn is now working - a contact was loose.

Problem with the speedo remains. I have tried to put my fingers in from above, but this seems really difficult... your fingers must be reeally slender :-)
Are you going with the hand in between the steering bar and the display, only feeling the contact? Or is it visible from any angle?

Benutzeravatar
takoda
Spezialist
Spezialist
Beiträge: 331
Registriert: 19. Mai 2016, 18:33
Wohnort: Wuppertal

Re: Horn signal and speedo (tacho) kaputt

Beitragvon takoda » 21. Apr 2018, 22:25

Can't deny I've got fairly slender hands (glove size 7 *lol*), but yeah, even for me it's a tight fit to go in from above beneath the display and the handlebar. I don't think there's any angle from which you have a chance to see the spot, gotta admit though I haven't checked that. Anyways, taking off at least the windshield and the fairing around the headlight is probably a good idea.
...still out here in the wind and rain ~ I look a little older but I feel no pain...

XF-Schwede
schaut sich noch um
schaut sich noch um
Beiträge: 19
Registriert: 24. Mai 2011, 21:36

Re: Horn signal and speedo (tacho) kaputt

Beitragvon XF-Schwede » 24. Apr 2018, 21:08

I demounted faring and display and treated the contact plug with electronic cleaner spray. Last year a similar problem was solved this way. But this time, no luck. The contact plug is on my bike inside a closed rubber sealing, so I cannot touch it with the cockpit in place, no matter how slender fingers are. Maybe your bike does not have that "rubber glove".

So I think the speedometer rotor is suspected. Is that what is called tacho rotor in this forum? Item 18A in this page: https://www.megazip.net/zapchasti-d...1 ... r-11714419

Is it possible to find out in any way if the rotor is broken, apart from changing it? I mean for example, can I see when taken out the wheel axle that the rotor is broken?

Benutzeravatar
Maad
Site Admin
Site Admin
Beiträge: 1140
Registriert: 19. Nov 2003, 21:06
Wohnort: Oberhausen

Re: Horn signal and speedo (tacho) kaputt

Beitragvon Maad » 24. Apr 2018, 22:32

Right! It is easy to check the damaged speedometer rotor . The wings are broken.
I repaired my rotor. I drilled a hole with a screwed thread in the cylindric part of the rotor. After that i put a plastic screw in it, filled it with 2component epoxy and formed it with a dremel.

This solution works for 6 or 7 years, so i got no pictures of it.

Regards
Marek

XF-Schwede
schaut sich noch um
schaut sich noch um
Beiträge: 19
Registriert: 24. Mai 2011, 21:36

Re: Horn signal and speedo (tacho) kaputt

Beitragvon XF-Schwede » 25. Apr 2018, 19:41

IMG_20180425_193943.jpg
Your guess was spot on. The wings on the rotor is totally worn out.

My question now is, the housing seems damaged too. Look at the picture. Will a new rotor work in this housing or is a whole new piece needed?

Benutzeravatar
Maad
Site Admin
Site Admin
Beiträge: 1140
Registriert: 19. Nov 2003, 21:06
Wohnort: Oberhausen

Re: Horn signal and speedo (tacho) kaputt

Beitragvon Maad » 26. Apr 2018, 08:31

It doesn't look so bad. Take a look after cleaning it.

ruhri
Spezialist
Spezialist
Beiträge: 1122
Registriert: 28. Jun 2006, 22:01
Wohnort: Mülheim an der Ruhr

Re: Horn signal and speedo (tacho) kaputt

Beitragvon ruhri » 26. Apr 2018, 10:51

Hi,

the sealing ring can be removed easily.
I don't think that the small plastic-parts from the broken rotor-wings can cause a damage of the housing.

Gruß
ruhri

XF-Schwede
schaut sich noch um
schaut sich noch um
Beiträge: 19
Registriert: 24. Mai 2011, 21:36

Re: Horn signal and speedo (tacho) kaputt

Beitragvon XF-Schwede » 10. Mai 2018, 21:17

Follow-up on this thread.

- Horn signal is working, the problem was a loose contact.
- Side stand killer started working without any action from me.
- Speedometer problem was the "tacho rotor" (magneto / speedo rotor). New part from Swedish dealer solved the problem, although the housing was a bit damaged. Since the part is not lying directly to the material in the housing (instead hold by magnet), it´s not necessary to have a perfect surface in the latter.

Vielen Dank für alle Antwort!

ruhri
Spezialist
Spezialist
Beiträge: 1122
Registriert: 28. Jun 2006, 22:01
Wohnort: Mülheim an der Ruhr

Re: Horn signal and speedo (tacho) kaputt

Beitragvon ruhri » 10. Mai 2018, 21:35

Hi,
XF-Schwede hat geschrieben:Side stand killer started working without any action from me.


I think, problems which solve themselves on their own are the best :D :D :D

Gruß
ruhri


Zurück zu „Suzuki XF650 Freewind“